General Information

WaferSense Teaching Wafer and Link

Changes or modifications not expressly approved by CyberOptics Semiconductor, Inc., may void your authority to operate the WaferSense ATS.

The radio contained in the WaferSense ATS meets all the applicable FCC requirements for RF Safety. While in operation, the FCC requires users and nearby persons to maintain a minimum separation distance of 20 cm (8 inches) or farther from the WaferSense ATS.

The WaferSense Teaching Wafer and Link have been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation. This equipment generates, uses and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of the following measures:

• Reorient or relocate the receiving antenna.
• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.
• Consult the dealer or an experienced radio/TV technician for help.

This device complies with part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) This device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation.

This ISM device complies with Canadian ICES-001.

Cet appareil ISM est conforme à la norme NMB-001 du Canada.
WaferSense Technical Support

Technical support is available from CyberOptics Monday through Friday, 8:00 A.M. to 5:00 P.M. Pacific Time.

    E-mail: CSsupport@cyberoptics.com
    For information about CyberOptics' offices
    and global support network, please visit

WaferSense is a registered trademark, and TeachView, and TeachTarget are trademarks of CyberOptics Corporation.

Third-party brands and names are the property of their respective owners.

Copyright © 2015, CyberOptics Corporation. All rights reserved.

P/N 920-0503-03 Rev. D
### Table of Contents

**General Information** ......................................................ii

**Chapter 1**
Introduction ..............................................................................1.1

**Chapter 2**
Installing Your ATS................................................................... 2.1
   Installing the Software ............................................................2.2
   Installing the Wireless Link.....................................................2.3
   Checking Communications Between the Link and the Wafer .....2.5
   Registering Your Teaching Wafer for Calibration Service...........2.6
   Running the TeachView Application .......................................2.7
   Technical Support ....................................................................2.9

**Chapter 3**
Using Your ATS........................................................................ 3.1
   Using the ATS Teaching Wafer Buttons and Status Lights .......3.2
   Finding a Target ........................................................................3.3
   Using the Target Overlay ........................................................3.8
   Using Find Once and Continuous Find ..................................3.10
      Taking a Single Reading..........................................................3.10
      Taking Continuous Readings ................................................3.10
   Setting the Target Criteria .....................................................3.11
   Setting the Wafer Display Orientation ...................................3.13
   Logging Your Readings ..........................................................3.15
      Logging a Reading .................................................................3.16
      Including User-Specified Information in the Log File ............3.17
      Changing the Log File ..........................................................3.18
      Working with Video Image Files ..........................................3.18
      Displaying Readings from a Log File ...................................3.18
   Printing the TeachView Window ............................................3.19
   Monitoring the Operating Temperature .................................3.20
Table of Contents

Using the Rechargeable Battery ................................................... 3.21
    Monitoring the Battery Level ............................................. 3.21
    Charging the Battery ...................................................... 3.21

Monitoring the Wireless Connection to the Teaching Wafer ...... 3.23
Changing the Pairing Between the Teaching Wafer and Link ...... 3.24
Saving Your Settings .................................................................... 3.25
    Loading Settings from a File ............................................. 3.25

Chapter 4
Viewing Log Files ........................................................................ 4.1
    Running TeachReview ................................................... 4.2
    Displaying the Target Overlay ........................................ 4.4
    Temporarily Changing the Target Criteria ............................ 4.5
    Temporarily Changing the Wafer Display Orientation ............ 4.7
    Changing Log Files .......................................................... 4.8
    Displaying Station and Wafer Information .............................. 4.9
    Printing the TeachReview Window ..................................... 4.10

Chapter 5
Creating Target Configuration Files ......................................... 5.1
    Choosing a Target ......................................................... 5.2
    Measuring the Target .................................................... 5.3
    Running TeachTarget .................................................... 5.4

Chapter 6
Maintaining Your ATS .............................................................. 6.1
    Annual Factory Calibration and Battery Replacement .......... 6.2
    Battery Use and Disposal ................................................. 6.3
    Updating Your ATS Wafer Firmware .................................. 6.4

Chapter 7
Specifications ............................................................................ 7.1
    System Requirements ..................................................... 7.1
    ATS Hardware .................................................................. 7.1
        Environmental ............................................................ 7.1
        Power ........................................................................ 7.1
        Range and Accuracy .................................................... 7.1

Index .................................................................................... Index.1
List of Illustrations

Chapter 1

Chapter 2

Figure 2.1: The InstallShield Wizard.......................................................2.2
Figure 2.2: Found New Hardware Wizard.............................................2.3
Figure 2.3: Installing the WaferLink Device..........................................2.4
Figure 2.4: Starting the TeachView Application....................................2.7
Figure 2.5: Calibration Registration Dialog..........................................2.8
Figure 2.6: The About TeachView Dialog..........................................2.9
Figure 2.7: The About your ATS Wafer Dialog.................................2.9

Chapter 3

Figure 3.1: The TeachView Application .................................................3.3
Figure 3.2: Aligning the Teaching Wafer..............................................3.4
Figure 3.3: Target Configuration List................................................3.5
Figure 3.4: Numeric Readouts..........................................................3.5
Figure 3.5: Target Centered in the Sight Ring....................................3.7
Figure 3.6: Target Overlay ................................................................3.8
Figure 3.7: Set Target Criteria Dialog.............................................3.12
Figure 3.8: Wafer Orientation in TeachView.................................3.13
Figure 3.9: Changing the Wafer Orientation ......................................3.14
Figure 3.10: Logging a Reading.........................................................3.16
Figure 3.11: Set Station Information Dialog.................................3.17
Figure 3.12: Temperature Monitoring Gauge.................................3.20
Figure 3.13: Battery Monitor..............................................................3.21
Figure 3.14: Wireless Connection Monitor.......................................3.23

Chapter 4

Figure 4.1: Running the TeachReview Application..............................4.2
Figure 4.2: Opening a Log File............................................................4.3
Figure 4.3: Target Overlay ................................................................4.4
Figure 4.4: Set Target Criteria Dialog..............................................4.5
Figure 4.5: Changing the Wafer Orientation.....................................4.7
Figure 4.6: Selecting a Log File..........................................................4.8
Figure 4.7: Station Information Dialog............................................4.9
List of Illustrations

Chapter 5
Figure 5.1: Aligning the Teaching Wafer ............................................................ 5.4
Figure 5.2: Step 1. Position the Wafer ............................................................... 5.5
Figure 5.3: Step 2. Optimize Lighting ............................................................... 5.6
Figure 5.4: Step 3. Acquiring Image ................................................................. 5.7
Figure 5.5: Step 4. Target Parameters .............................................................. 5.8
Figure 5.6: Step 4. Secondary Target Parameter ............................................ 5.9
Figure 5.7: Step 5. Overlay Alignment, Primary Target ................................. 5.10
Figure 5.8: Step 5. Overlay Alignment, Secondary Target .............................. 5.11
Figure 5.9: Step 6. Generating Target Parameters ......................................... 5.12

Chapter 6
Figure 6.1: ATS Wafer Calibration Status Dialog ......................................... 6.2
Figure 6.2: Starting the ATS Firmware Updater Application ........................ 6.4
Figure 6.3: Cycle Power dialog ....................................................................... 6.5

Chapter 7
Chapter 1

Introduction

The CyberOptics Semiconductor WaferSense® Automatic Teaching System (ATS) measures three-dimensional offsets to teach wafer handoff positions. Using machine vision technology, it “sees” targets inside semiconductor equipment. The TeachView™ software application makes it easy to precisely adjust equipment. The large display and wireless link let you place the computer at a convenient distance from the teaching wafer.

ATS consists of the following components:

- **Teaching wafer.** The ATS is designed with a wafer-like form factor, so it can fit in most wafer-handling equipment. The teaching wafer is also vacuum compatible.

- **TeachView, TeachReview™, and TeachTarget™ software.** The TeachView software application monitors the teaching wafer and displays X, Y, and Z offsets and other status information in real time. TeachReview lets you play back log files recorded in TeachView. TeachTarget creates target configuration files needed by TeachView. All three applications run on most personal computers that use the Microsoft Windows operating system.

- **Wireless link.** The software communicates with the teaching wafer by using a Bluetooth wireless link that attaches to a USB port on a personal computer.

- **Charging clean box.** The teaching wafer is powered by an internal rechargeable battery, which you recharge by placing the teaching wafer into the charging clean box.

- **Carrying case.** The carrying case makes it easy to take your complete ATS system with you in the plant or on the road.

The following chapter gives you instructions for installing your ATS system.
Chapter 2

Installing Your ATS

This chapter describes the procedures you need to perform to install your ATS and get it ready for use. For best results, perform the procedures in the order they are presented in this chapter:

1. Installing the software
2. Installing the wireless link on the USB port
3. Checking communications between the link and the teaching wafer
4. Registering your teaching wafer
5. Running the TeachView application

Caution

Dropping the teaching wafer or hitting it against a hard object can bend, break, or chip the housing; damage the internal components; or knock the teaching wafer out of calibration. While it is not as fragile as an actual silicon wafer, handle the teaching wafer with care, as you would any precision instrument. If the teaching wafer is damaged or in need of calibration, see Chapter 6, “Maintaining Your ATS.”
Installing the Software

To run the WaferSense ATS software, your computer must have the following:
- Windows XP, Windows Vista (32/64), or Windows 7 (32/64) operating system
- One free high-power USB 1.1 or USB 2.0 port

To install the WaferSense ATS software:

1. Log on using an account with Administrator privileges.
2. Insert the WaferSense ATS Installation Disk into the CD drive.
   The InstallShield Wizard starts automatically, as shown in Figure 2.1. If the wizard doesn’t start automatically, use Windows Explorer to view the contents of the CD and double-click the setup.exe program.
3. Follow the instructions provided by the wizard to install the software.
4. After you complete the instructions for all of the wizard screens, click Finish. If Windows notifies you that the drivers have not passed Windows logo testing, just click Continue Anyway to complete the installation.

By default, the Setup program installs the TeachView, TeachReview, and TeachTarget applications in a new program group called WaferSense ATS. Setup also installs an online copy of this user’s guide, which is available from the TeachView, TeachReview, and TeachTarget Help menus and in the WaferSense ATS program group in the Windows Start menu.
Chapter 2. Installing Your ATS

Installing the Wireless Link

To install the wireless link:

1. Turn on your computer.
2. Locate an unused, high-power USB port on your computer. The ATS wireless link module requires a high-power USB port, such as the built-in ports on your computer and ports on USB hubs that have power cords. Unpowered USB hubs won’t work.
3. The USB cable provided with your ATS has a different plug on each end. Locate the end with the plug that matches the USB port on your computer and plug the cable into the port.
4. Plug the other end of the cable into the link module.
   The Windows operating system recognizes the new link module hardware and displays the Found New Hardware Wizard, as shown in Figure 2.2. If the wizard your system displays doesn’t offer to check with Windows Update, skip to step 5.

![Found New Hardware Wizard](image)

Figure 2.2: Found New Hardware Wizard

5. Choose No, not this time and click Next.
The wizard offers to help you install software for the CyberOptics WaferSense link device, as shown in Figure 2.3.

![Found New Hardware Wizard]

**Figure 2.3: Installing the WaferLink Device**

6. Choose **Install the software automatically** and click **Next**.
   
   If you already installed the WaferSense ATS software (see “Installing the Software,” on page 2.2), Windows will automatically find the drivers. If not, the drivers are located in the Utilities folder on the installation CD-ROM.

7. After you complete the instructions for all of the wizard screens, click **Finish**.
   
   The **Power** light on the module turns on indicating that the module is getting power from the USB port. Ignore the **Pair Status** and **Connection Status** lights for now.
Chapter 2. Installing Your ATS

Checking Communications Between the Link and the Wafer

To complete the installation, verify that the teaching wafer and link can communicate:

1. The teaching wafer operates from an internal rechargeable battery. Before using the teaching wafer for the first time, charge it for two hours. For information on checking the charge on the battery and the procedure for recharging, see “Using the Rechargeable Battery,” on page 3.21.

2. Remove the teaching wafer from the charging clean box and press the ON OFF button to turn on the teaching wafer.

   The On light on the teaching wafer turns on.

3. Verify that the Pair Status lights on both the teaching wafer and link module are on. If either light is not on, your teaching wafer and link might not be paired with each other. To reset the pairing, see “Changing the Pairing Between the Teaching Wafer and Link,” on page 3.24.

4. Immediately after turning on the teaching wafer, the Connection Status lights on the teaching wafer and link will blink slowly. After a few seconds the teaching wafer and link will connect and both lights will be on and no longer blinking. If the lights continue to blink, see “Monitoring the Wireless Connection to the Teaching Wafer,” on page 3.23.

5. After starting the TeachView application (see “Running the TeachView Application,” on page 2.7), you can verify the connection to the teaching wafer by comparing the serial number printed on the teaching wafer to the serial number shown in the About your ATS Wafer dialog, which is available in the TeachView application by choosing the Help > About your ATS Wafer menu item. If neither the TeachView nor the TeachTarget application is running, the ATS wafer turns off automatically after 30 minutes.

That completes the installation of your ATS.
Registering Your Teaching Wafer for Calibration Service

To maintain optimum performance, every twelve months you should have your teaching wafer calibrated and the battery replaced. These services can be performed only at the factory.

To help you keep track of the next service date so you can schedule this service when it is convenient, register your WaferSense ATS teaching wafer with the factory. When you start the TeachView application (see “Running the TeachView Application,” on page 2.7), it prompts you to register your teaching wafer for calibration. You can also register your teaching wafer in any of the following ways:

- By sending an e-mail message containing the model, serial number, and contact information to: wsregister@cyberoptics.com
Running the TeachView Application

To start the TeachView application:

1. From the Windows Start > All Programs menu, choose WaferSense ATS > TeachView.

The TeachView application starts, as shown in Figure 2.4. Initializing communications usually takes less than a second. For information on using TeachView, see Chapter 3, “Using Your ATS.” If you haven’t registered your teaching wafer, TeachView also displays the Calibration Registration dialog. To complete the registration, proceed to the next step.

![Figure 2.4: Starting the TeachView Application](image)

2. If TeachView displays the WaferSense ATS Calibration Registration dialog, as shown in Figure 2.5, you haven’t registered your teaching wafer. Follow the instructions in the dialog to complete the registration.
Chapter 2. Installing Your ATS

Figure 2.5: Calibration Registration Dialog

The TeachReview application is described in Chapter 4, “Viewing Log Files.” The TeachTarget application is described in Chapter 5, “Creating Target Configuration Files.”
Technical Support

CyberOptics Semiconductor offers free technical support to customers. If the ATS hardware or software appear to be malfunctioning, please contact us, and we'll be happy to assist you.

When you contact us, please make sure that you have the following information available:

- A detailed description of the problem you are having, including the exact text of any error messages and a list of steps to reproduce the problem.
- Information about your computer, including manufacturer, CPU type, version of Windows, and memory size.
- The version of the TeachView application. The software version is available in the TeachView application by choosing the Help > About TeachView menu item.

![About TeachView Dialog](image1)

Figure 2.6: The About TeachView Dialog

If you are using TeachReview or TeachTarget, similar dialogs are available from the Help > About TeachReview and the Help > About TeachTarget menu items.

- The serial number of your teaching wafer. The serial number of the teaching wafer is printed on a label on the top of the teaching wafer. The serial number is also available in the TeachView application by choosing the Help > About your ATS Wafer menu item.

![About your ATS Wafer Dialog](image2)

Figure 2.7: The About your ATS Wafer Dialog
Technical support is available Monday through Friday, 8:00 A.M. to 5:00 P.M. Pacific Time.

- Toll free: 800-366-9131 (US and Canada only)
- E-mail: CSsupport@cyberoptics.com
- Internet: www.Cyberoptics.com
Using Your ATS

This chapter provides instructions for performing the following tasks with the ATS:

- Using the ATS teaching wafer buttons and indicators
- Performing a basic target measurement
- Using the target overlay
- Using find once and continuous find
- Setting the target criteria for measurements
- Setting the wafer display orientation
- Logging your readings
- Printing the TeachView window
- Monitoring the operating temperature
- Using the rechargeable battery
- Monitoring the connection between the teaching wafer and link module
- Changing the pairing between the teaching wafer and link module.
- Saving your settings
Using the ATS Teaching Wafer Buttons and Status Lights

ATS teaching wafers have two buttons:

- **ON OFF.** Turns the teaching wafer on and off. If neither the TeachView nor the TeachTarget application is running, the ATS wafer turns off automatically after 30 minutes.
- **NEW PAIR.** Changes the pairing between a teaching wafer and a link (see “Changing the Pairing Between the Teaching Wafer and Link,” on page 3.24).

ATS teaching wafers also have the following status lights:

- **On.** Glows red while the teaching wafer is turned on.
- **Charging.** Glows red when the teaching wafer is being charged in the charging case.
- **Charging Done.** Glows red when the battery has reached at least 90% of full charge.
- **Connection Status.** Glows red when the teaching wafer has established communication with the link. Blinks slowly while the teaching wafer is trying to establish a connection with the link.
- **Pair Status.** Glows red when the teaching wafer is paired with a link (see “Changing the Pairing Between the Teaching Wafer and Link,” on page 3.24).
Finding a Target

The camera in the teaching wafer captures live video from within the semiconductor process equipment. An image processor in the wafer reports the coordinates (X, Y, Z) of the teaching wafer in relation to a target on the equipment. When you tell ATS to find the target, the TeachView application displays the coordinates.

In the video image displayed in TeachView, the center of the field of view for the teaching wafer is indicated by red cross hairs that span the length and width of the video image (see Figure 3.1). A red circle is centered on the cross hairs and serves as a sight ring for aligning the target image. When the target is within the sight ring, the equipment is aligned within the specified tolerances. For more information on setting tolerances, see “Setting the Target Criteria,” on page 3.11.

Figure 3.1: The TeachView Application
To find a target:

1. Make sure the computer running the TeachView application is within the range of the link module, up to 30 ft (10 m).

2. Place the teaching wafer on the equipment you want to check. Align the teaching wafer so it matches the TeachView display by rotating the wafer until the WaferSense™ ATS logo is right-side up and level as you face the wafer, as shown in Figure 3.2.

Figure 3.2: Aligning the Teaching Wafer

The teaching wafer also has a notch or flat on one side. When you have the teaching wafer aligned as described above, the notch or flat will be in the 3 o’clock position as you face the teaching wafer.

You can change the orientation of the teaching wafer in the TeachView display. For example, if you have equipment where the wafer must be oriented with the notch or flat in the 6 o’clock position, you could set TeachView to display the wafer in that position (see “Setting the Wafer Display Orientation,” on page 3.13).
3. From the Target configuration list (see Figure 3.3), choose the appropriate target configuration file for the equipment you are working on. If the file isn’t shown in the list, choose Browse, which is always the last entry in the Target configuration list, or choose the menu item File > Select Target Configuration File to locate the file. If you don’t choose a target configuration file, ATS can’t search for the target, and the Find Once button and Continuous find box are disabled. For information on creating target configuration files, see “Creating Target Configuration Files,” on page 5.1.

![Figure 3.3: Target Configuration List](image)

4. Click Find Once (see Figure 3.4).

After a few seconds, the teaching wafer finds the target and sends the information to the TeachView application. TeachView displays the measurements in numeric readouts (see Figure 3.4).

![Figure 3.4: Numeric Readouts](image)

Readings are shown in units of inches or millimeters. To change the units, see “Setting the Target Criteria,” on page 3.11.
Readings outside the working range of the teaching wafer are displayed as ####. If the readings display **None**, ATS was not successful in finding the target. This can be caused by the following:

- **Target too far off center.** The farther the target is initially from the center of the field of view of the teaching wafer, the harder it is for ATS to find the target. Move the teaching wafer so that the target appears closer to the sight ring and try finding the target again. If you are having trouble seeing the target in the video image, you can adjust the image by choosing the menu item **Settings > Optimize Lighting**.

- **Target criteria.** You might not have the target criteria set correctly. For more information, see “Setting the Target Criteria,” on page 3.11. In particular, verify that the Z distance you have specified in the target criteria is within 1 mm (0.0394 inches) of the Z distance used to create the target configuration file. The acceptable range for the Z distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.12).

- **Wafer to target distance.** You might have the teaching wafer too close or too far from the target. The distance from the bottom of the teaching wafer to the target should be within 1 mm (0.0394 inches) of the Z distance used to create the target configuration file. The acceptable range for the Z distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.12).

- **Target configuration file.** You chose the wrong target configuration file or the target configuration file is not correct. Verify that you are using the correct file. For more information on target configuration files, see “Creating Target Configuration Files,” on page 5.1.

You can use these X, Y, and Z measurements to adjust the equipment to center the target in the sight ring.
5. Adjust the equipment and click **Find Once** again. Repeat this process until the target is centered in the sight ring, and the X and Y values are zero or close enough (see **Figure 3.5**).

![Figure 3.5: Target Centered in the Sight Ring](image)

You can resize the TeachView window to make the video image larger or smaller. The numeric readouts and other controls don't change size when you change the size of the TeachView window.

For information on the accuracy of the readings, see “Range and Accuracy,” on page 7.1.
Using the Target Overlay

A target overlay feature lets you verify that the ATS has correctly identified the target.

To activate the target overlay:

- Check **Display target overlay** below the numeric readouts. The target overlay appears as a circle with cross hairs, as shown in Figure 3.6.

![Target Overlay](image)

**Figure 3.6: Target Overlay**

The target overlay should be centered on the image of the target, as shown in Figure 3.6. The target overlay changes from yellow to green when the target is centered in the sight ring to within the specified tolerances and the Z target distance is within tolerance (see “Setting the Target Criteria,” on page 3.11). After you instruct the ATS to find the target, if the overlay is not centered on the target, the ATS is not correctly recognizing the target. If the target doesn't overlay the feature in the image, check the following:

- **Video stopped.** Maker sure the wafer is still sending live video. You can do this by moving the wafer a small amount and watching the video image. If the video isn't tracking the movement, turn off the wafer and then turn it back on.

- **Target too far off center.** The farther the target is initially from the center of the field of view of the teaching wafer, the harder it is for ATS to find the target. Move the teaching wafer so that the target appears closer to the sight ring and try finding the target again. If you are having trouble seeing the target in the video image, you can adjust the image by choosing the menu item **Settings > Optimize Lighting**.
Chapter 3. Using Your ATS

- **Target criteria.** You might not have the target criteria set correctly. For more information, see “Setting the Target Criteria,” on page 3.11. In particular, verify that the Z distance you have specified in the target criteria is within 1 mm (0.0394 inches) of the Z distance used to create the target configuration file. The acceptable range for the Z distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.12).

- **Wafer to target distance.** You might have the teaching wafer too close or too far from the target. The distance from the bottom of the teaching wafer to the target should be within 1 mm (0.0394 inches) of the Z distance used to create the target configuration file. The acceptable range for the Z distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.12).

- **Target configuration file.** You chose the wrong target configuration file or the target configuration file is not correct. Verify that you are using the correct file.
Using Find Once and Continuous Find

You can instruct the teaching wafer to take a single reading of the target position or to make continuous readings.

Note that whether you are taking a single reading or continuous readings, the video image is updated continuously.

Taking a Single Reading

As described in “Finding a Target,” on page 3.3, you can use the Find Once button to have the ATS make a single measurement of the target coordinates. After the measurement is completed and the results are displayed, you can adjust the equipment as needed.

Note
In find once mode, when you make adjustments that cause the target to move, the coordinates displayed in the TeachView window no longer reflect the correct position of the target. After adjusting the position of the wafer, always click Find Once again to update the readings.

Taking Continuous Readings

Rather than taking a single measurement, you can have the teaching wafer take continuous measurements. When the ATS is in continuous find mode, it sends readings to the TeachView application every two to three seconds and the readouts are updated each time new readings are received.

To activate continuous find:

• Check the Continuous find box located just above the Find Once button.

While the Continuous find box is checked, the Find Once button is disabled. To cancel continuous find, uncheck the box.
Setting the Target Criteria

When you have successfully centered the target within the sight ring, the X and Y coordinates will both ideally be zero. In practice, you might not need to have them exactly zero, just close enough. You can specify your desired tolerances for the target measurement. As long as you position the target within the sight ring, you know that it is centered within your specified tolerances.

In addition to specifying tolerances for the X and Y measurements, you can specify a target value and tolerance for the Z coordinate. The specified range for Z is 6.4 mm – 45 mm (0.25 inches – 1.8 inches). The target configuration file that TeachView uses to recognize a given target is created from an image of the target that was captured at a specific Z value (for more information, see “Creating Target Configuration Files,” on page 5.1). When you use a particular target configuration file, the teaching wafer will be able to recognize the target more successfully if the wafer is at the same Z value that was used to create the target configuration file. Specifying a target Z value and tolerance makes it easy to tell when the teaching wafer is at the proper height.

You can set separate tolerance values for the X and Y measurements, or you can specify a single tolerance value for both measurements.

Tolerances and target values can be in units of inches or millimeters. The units you select in the Set Target Criteria dialog will also be used to display readings and other values in the main window.
To specify the target criteria:

1. Choose the menu item **Settings > Set Target Criteria**.
   
The Set Target Criteria dialog is displayed, as shown in **Figure 3.7**.

![Set Target Criteria Dialog](image)

**Figure 3.7: Set Target Criteria Dialog**

2. In the **Units** section, choose the units of measurement, inches or millimeters. This selection affects all values in the dialog and in the main TeachView window.

3. To specify one tolerance for both X and Y measurements, check the box for **x and y the same**. To specify the tolerance separately for each, uncheck the box. When you check the box, the dialog changes to display only one set of tolerance criteria for both X and Y.

4. Fill in the tolerances you want to specify. Tolerances must be entered as positive numbers and must be in the range 0.01 mm to 2.0 mm (0.0004 inches to 0.0787 inches).

5. If you don’t want to set a target value for the Z measurement, check the box **ignore target Z value**. Otherwise, uncheck the box and fill in your desired value for **Target Z value**. The value must be within one millimeter (0.0394 inches) of the value specified in the target configuration file (the range, Z ± 1 mm or Z ± 0.0394 inches, is shown at the bottom of the dialog). When is **ignore target Z value** checked, the Z reading and the tolerances for Z and **Target Z** in the main window appear dimmed as a reminder.

6. Click **OK**.
### Setting the Wafer Display Orientation

Checking and adjusting equipment is easier if you can place the teaching wafer in the equipment in the same orientation as it is shown in the TeachView display. By default, the wafer is displayed in TeachView with the notch in the 3 o’clock position, as shown on the left in Figure 3.8.

![Figure 3.8: Wafer Orientation in TeachView](image)

If you have a piece of equipment that requires the wafer to be in a different orientation, you can tell TeachView to rotate the displayed wafer to any of four positions: 3, 6, 9, or 12 o’clock. For example, the wafer display on the right in Figure 3.8 is shown with the notch at the 6 o’clock position.

The displayed X and Y readings and tolerances are always relative to the horizontal X axis and the vertical Y axis of the video image, regardless of the orientation of the wafer. This means that when you change the wafer orientation by 90 degrees, the X and Y readings change places, and either the X reading or the Y reading changes sign. For example, let’s assume you have readings of X=-1.5 mm and Y=2.0 mm with the default orientation (notch at 3 o’clock). If you change the wafer orientation so that the notch is at 6 o’clock, the readings will change to X=2.0 mm and Y=1.5 mm. Similarly, when you change the wafer orientation by 90 degrees, the X and Y tolerances change places. Tolerances are always positive values, so they never change sign.
To change the orientation of the wafer in the TeachView display:

- Choose the desired orientation from the **Notch at:** menu in the Readings section of the display (Figure 3.9).

![Figure 3.9: Changing the Wafer Orientation](image-url)
Loggng Your Readings

TeachView can keep a record of your activities as you use the teaching wafer to check various pieces of equipment. TeachView keeps the record in a log file. TeachView also records a copy of the video image that is displayed at the time an entry is logged. These video images are stored as separate bitmap (.bmp) files in a subdirectory. You can specify the log file path (see “Changing the Log File,” on page 3.18). The log file contains the following information for each entry:

- **Date and Time.** The date and time of the log file entry.
- **Target configuration file.** Path name for the currently selected target configuration file (see “Finding a Target,” on page 3.3).
- **X, Y, and Z readings.** Measurements for the X, Y, and Z coordinates of the target.
- **X, Y, and Z Tolerances.** The user-specified tolerance for each coordinate measurement (see “Setting the Target Criteria,” on page 3.11).
- **Z target value.** The user-specified target value for the Z measurement, the height of the teaching wafer above the target (see “Setting the Target Criteria,” on page 3.11).
- **Tolerance met.** Whether the coordinate measurements were within tolerances.
- **Z target ignored.** Whether the Z value is ignored in deciding if the current readings are within tolerance (see “Setting the Target Criteria,” on page 3.11).
- **Temperature.** The current operating temperature of the teaching wafer in °C (see “Monitoring the Operating Temperature,” on page 3.20).
- **Battery.** The percentage of time remaining before the battery must be recharged (see “Using the Rechargeable Battery,” on page 3.21).
- **Serial number.** The serial number of the teaching wafer.
- **Days since factory calibration.** Number of days since last factory calibration of the wafer (“Annual Factory Calibration and Battery Replacement,” on page 6.2).
- **Display Units.** Inches or mm.
- **Notch Direction.** Orientation of the wafer notch in the video display: 3, 6, 9, or 12 o’clock.
- **Bitmap Directory.** Subdirectory where bitmaps of the video images are stored.
- **Bitmap File.** Name of the bitmap file in the bitmap subdirectory for the video image associated with the log entry.
- **Operator, Tool, Station, and Comment.** Text fields you can use to record your own information with each log entry (see “Including User-Specified Information in the Log File,” on page 3.17).
Chapter 3. Using Your ATS

The remainder of this section describes how to:

- Log a reading
- Include additional information in a log entry: operator, tool, station, and comment
- Change the pathname for the log file
- Work with video image files
- Display readings from a log file

**Logging a Reading**

TeachView posts entries to the log file and saves the corresponding video images on your command.

To post an entry to the log file and save the video image:

- In the main TeachView window, click **Log a Reading** (see Figure 3.10).
  
  TeachView immediately writes a log entry and saves the video image each time you click the button.

![Log a Reading button](image)

**Figure 3.10: Logging a Reading**
Including User-Specified Information in the Log File

Operator, Tool, Station, and Comment are text fields you can use to record your own information with each log entry. You can fill in any text information you want in these fields.

To include user-specified information for logging:

1. Choose the Settings > Set Station Information menu item.
   
   The Set Station Information dialog is displayed, as shown in Figure 3.11.

![Set Station Information Dialog](image)

   **Figure 3.11: Set Station Information Dialog**

2. Type your text into the Operator, Tool, Station, and Comment text fields.

3. Click Apply to accept the changes without closing the dialog. To accept the changes and close the dialog, click OK instead.

   You can leave the Set Station Information dialog open while using TeachView (drag it off to the side, so it doesn’t cover the TeachView window). Doing so makes it easy to change the Comment or other fields each time you log a reading, or as needed. Be sure to click Apply after you finish making changes, though, or TeachView won’t use the latest changes for the next log entry.

   You can change or delete this information at any time for future log entries. To quickly clear all of the fields, click Clear All.
Chapter 3. Using Your ATS

Changing the Log File

By default, TeachView writes log entries to the file My Documents\ATS Files\ATS Readings.csv. If you prefer, you can specify a different log file. The name of the current log file is displayed below the Log a Reading button (see Figure 3.10 on page 3.16).

To change the log file:

1. Choose the File > Select Log File menu item.
2. In the ATS Log File dialog, specify the folder and file name for the log file, and click Save.

Working with Video Image Files

When you log a reading, TeachView also saves the video image as a bitmap (.bmp) file. You can view these files along with the log file entries by using the TeachReview application described in Chapter 4, “Viewing Log Files.” You can also view the video files in any application program that can display standard Windows bitmap files.

Video image files are stored in a subdirectory named for the associated log file. For example, for the default log file, ATS Readings.csv, the subdirectory is named ATS Readings. The TeachReview application assumes that the log files will be in a subdirectory named for the log file. If you move the log file, you should always move the subdirectory with along with the log file. Otherwise, TeachReview won’t be able to find and display the video image for a corresponding log file entry.

Displaying Readings from a Log File

The TeachReview application makes it easy to view entries from a log file and the associated video images. For more information on TeachReview, see Chapter 4, “Viewing Log Files.”

Log files are saved in a comma-separated-values (CSV) text format. The file is read-only to avoid accidental data corruption. Files in CSV text format are easy to import into spreadsheet and word processing programs.

Caution

If you edit a log file in a spreadsheet or other application, TeachReview might not be able to read the file. If you need to edit a log file, you should make a copy of the log file in another directory, and then edit the copy.
Printing the TeachView Window

You can print an image of the TeachView window to have a graphical record of the session.

To print an image of the TeachView window:

1. Choose File > Print.
2. In the Print dialog, click OK.

You can also select a printer other than the default and change the printer setup, or see a preview of what TeachView will print:

- To select a different printer, change the paper selection or print orientation, or set printer properties, choose the File > Print Setup menu item.
- To see a preview of what TeachView will print, choose the File > Print Preview menu item.
Monitoring the Operating Temperature

The operating range for the teaching wafer to achieve the specified accuracy for readings is 20 °C to 50 °C. The teaching wafer can withstand exposure to 120 °C (5 minutes or less) if not in direct contact with the heating element. The Temperature monitor in the ATS wafer status area of the TeachView window (see Figure 3.12) shows the current operating temperature of the teaching wafer with a numeric readout and a bar graphic.

![Temperature Monitoring Gauge](image)

**Figure 3.12: Temperature Monitoring Gauge**

The temperature bar changes color to indicate where the current temperature is relative to the accurate operating range:

- **Blue.** Less than 20 °C; the teaching wafer is operating below the range where it produces accurate readings.
- **Green.** 20 °C to 50 °C; the teaching wafer is operating in its optimum temperature range, where it produces readings meeting the specified accuracy.
- **Orange.** 51 °C to 60 °C; the teaching wafer is operating above the range where it produces the most accurate readings, but not so hot that the teaching wafer will be damaged.
- **Red.** Greater than 60 °C; the teaching wafer is operating at a temperature so high that it might be damaged.
Using the Rechargeable Battery

The teaching wafer operates from an internal rechargeable battery. From a full charge, the battery provides about two hours of continuous use. Before using your teaching wafer for the first time, charge it for two hours.

The battery can be recharged about 500 times before the charge life starts to degrade significantly. The battery is not user replaceable. For information on replacing the battery, see “Annual Factory Calibration and Battery Replacement,” on page 6.2.

Battery performance degrades at temperatures outside the optimum operating temperature range: 20 °C - 50 °C.

Monitoring the Battery Level

TeachView receives frequent updates from the teaching wafer on the state of the teaching wafer’s battery. The Battery indicator in the ATS wafer status area of the TeachView window shows the approximate percentage of operating time remaining before you must charge the battery.

![ATS wafer status](image.png)

Figure 3.13: Battery Monitor

Charging the Battery

To charge the teaching wafer’s battery:

1. Use only the battery charger supplied with your teaching wafer. Using a different battery charger might damage your teaching wafer or create a safety hazard.

2. Do not charge the teaching wafer if its internal temperature is higher than 45 °C. Charging the teaching wafer at a temperature higher than 45 °C might damage your teaching wafer or create a safety hazard.

3. Place the teaching wafer in the charging clean box. Rotate the wafer until the WaferSense ATS logo is right side up and approximately level when the hinged edge of the box is away from you. Close the lid.
4. Plug the charger line adapter into a 100 VAC to 240 VAC supply and plug the other end into the charging clean box.

The Charging light is on while the teaching wafer is charging. If the Charging light does not turn on, make sure the lid of the box is closed completely and the charging pins in the charging clean box are making electrical contact with the teaching wafer.

When you first start charging the wafer, it turns on. After about 10 minutes, if TeachView and TeachTarget aren’t running, the wafer will turn off and continue to charge.

5. Charge the teaching wafer until the Charging Done light turns on or until you need to use the teaching wafer (you don’t need to wait until the teaching wafer is fully charged).

Fully charging the battery takes about two hours. Charging for one hour charges the battery to about 80% of its capacity. You can leave the teaching wafer in the charging case when not in use; the battery won’t overcharge.
Monitoring the Wireless Connection to the Teaching Wafer

The TeachView application communicates with the teaching wafer by using a Bluetooth wireless link. The wireless link has a range of up to 30 ft (10 m).

The **Connection** indicator in the **ATS wafer status** area of the TeachView window shows the quality of the wireless connection between the teaching wafer and the link module. The connection quality is indicated by the color of the bar and the wording below the bar (see Figure 3.14):

- **Green - Connected.** The connection between the link and teaching wafer is good. With a good connection, the teaching wafer is sending the maximum number of readings per second to the link module (about one reading every two to three seconds).
- **Yellow - Poor connection.** There is some interference or other problem with the signal that is preventing the link and teaching wafer from communicating at their maximum rate. When the indicator is yellow, the readings are still accurate but aren’t being updated as frequently.
- **Red - No connection.** Indicates that there is no connection between the teaching wafer and link module. The values in the display do not update when the indicator is red.

![ATS wafer status](image)

**Figure 3.14: Wireless Connection Monitor**

The Bluetooth wireless link technology used in the ATS is a low-power technology that operates in the 2.4 GHz radio frequency band. This unlicensed band is also used by many other types of devices, such as cordless phones and microwave ovens. Another 2.4 GHz device operating in close proximity could interfere with the ATS system. When this happens, separating the devices by at least 6 ft (2 m) usually solves the problem.

Other factors can also affect the wireless link, such as the distance between the teaching wafer and link, and obstacles between the teaching wafer and link that block the signal. If TeachView
indicates that the connection isn’t good, try moving the wireless link module a few feet closer to the teaching wafer.

After turning off the teaching wafer, the Connection indicator might not change to red for a few seconds.

**Changing the Pairing Between the Teaching Wafer and Link**

Each teaching wafer is paired with a specific link module at the factory and will operate with only that particular link module. However, you can change this pairing, so that you can use your teaching wafer with a different link module, or vice versa.

To pair a teaching wafer and link module:

1. If you are changing the pairing of a teaching wafer that is already paired with a link module, first unplug the currently paired link module. You can’t pair a teaching wafer with a new link module while the currently paired link module is powered on.

2. Make sure the **Power** light is illuminated on the link module you want to pair, and make sure the **On** light is illuminated on the teaching wafer.

3. On the teaching wafer, press and hold the **NEW PAIR** button until the **Pair Status** and **Connection Status** lights start to blink rapidly (about four times per second).

4. On the link module, press and hold the **NEW PAIR** button until the **Pair Status** and **Connection Status** lights start to blink rapidly (about four times per second).

The **Pair Status** and **Connection Status** lights will continue to blink until the teaching wafer and link have established a new pairing, after which the lights will be on and no longer blinking.
Saving Your Settings

Each time you exit the TeachView application, it saves your current settings for the log file; X, Y, and Z tolerances; Z target value; target overlay; units (mm or inches); wafer notch orientation; and find state (continuous or find once) in the Windows registry. The next time you start TeachView, it restores those saved settings. You can also tell TeachView to save your settings to a file you specify, and you can have TeachView read those settings back at any time. This lets you have several different configurations for TeachView and be able to switch between them easily, without having to reenter the settings.

To save your settings in a file you specify:

1. Choose the File > Save Settings As menu item.
2. In the ATS Settings File dialog, specify the directory and file name and click Save.

TeachView saves your settings, and the file you specified becomes the current settings file.

To save your settings in the current settings file:

• Choose the File > Save Settings menu item.

Each time you start TeachView, the application automatically reads in the most recent settings from the Windows registry, including the last settings file you specified, if any.

Loading Settings from a File

To load settings from a file:

1. Choose the File > Open Settings menu item.
2. In the ATS Settings File dialog, specify the directory and file name and click Open.

TeachView reads the settings from the specified file and applies the settings. These settings are also written to the Windows registry and will be loaded the next time you start the TeachView application.
Chapter 4

Viewing Log Files

The TeachReview application lets you view log files that you previously recorded using TeachView. This chapter gives you instructions for performing the following tasks with the TeachReview:

• Running TeachReview
• Displaying the target overlay
• Temporarily changing the target criteria
• Temporarily changing the wafer display orientation
• Changing log files
• Displaying station and wafer information
• Printing the TeachReview window

This chapter assumes that you are familiar with the information in Chapter 3, “Using Your ATS.”
Running TeachReview

To view a log file:

1. From the Windows **Start > All Programs** menu, choose **WaferSense ATS > TeachReview**.
   
The TeachReview application starts, as shown in **Figure 4.1**.

![Figure 4.1: Running the TeachReview Application](image)

2. From the **File** menu, choose **Open Log File**. The ATS Log File dialog is displayed.
3. Choose a log file and click **Open**. TeachReview opens the log file and displays the data for the first entry in the file (see **Figure 4.2**).

**Figure 4.2: Opening a Log File**

If TeachReview can’t locate the video image file for a particular log file entry, the video display will be blank. This can happen if you move the log file without also moving the associated subdirectory. For more information, see “Working with Video Image Files,” on page 3.18.

4. To view the data for a different entry in the log file, use the **Next** and **Previous** buttons, or choose an entry from the **Select an entry** list.
Displaying the Target Overlay

A target overlay feature lets you verify that the ATS has correctly identified the target.

To activate the target overlay:

- Check Display target overlay below the numeric readouts. The target overlay appears as a circle with cross hairs, as shown in Figure 4.3.

![Figure 4.3: Target Overlay](image)

A green target overlay indicates that the target is centered to within your specified tolerances. When the target is outside the tolerances, the target overlay appears yellow.
Temporarily Changing the Target Criteria

The target criteria in effect at the time a log file entry is made are recorded in the log file as part of the log entry. Those values are used when you first display an entry from the log file. You can temporarily change the target criteria for the entry you are currently viewing. However, as soon as you select a new entry from the log file, the target criteria displayed revert to that of the log file entry. For more information, see “Setting the Target Criteria,” on page 3.11.

To temporarily change the target criteria:

1. Choose the menu item Settings > Set Target Criteria.

   The Set Target Criteria dialog is displayed, as shown in Figure 4.4.

   ![Set Target Criteria Dialog](image)

   **Figure 4.4: Set Target Criteria Dialog**

2. In the Units section, choose the units of measurement, inches or millimeters. This selection affects all values in the dialog and in the main TeachView window.

3. To specify one tolerance for both X and Y measurements, check the box for x and y the same. To specify the tolerance separately for each, uncheck the box. When you check the box, the dialog changes to display only one set of tolerance criteria for both X and Y.

4. Fill in the tolerances you want to specify. Tolerances must be entered as positive numbers and must be in the range 0.01 mm to 2.0 mm (0.0004 inches to 0.0787 inches).
5. If you don’t want to set a target value for the Z measurement, check the box `ignore target Z value`. Otherwise, uncheck the box and fill in your desired value for `z target value`. The value must be within one millimeter (0.0394 inches) of the value specified in the target configuration file (the range, Z ± 1 mm or Z ± 0.0394 inches, is shown at the bottom of the dialog). When is `ignore target Z value` checked, the Z reading in the main window will appear dimmed as a reminder.

6. Click OK.
Temporarily Changing the Wafer Display Orientation

By default, the wafer is displayed in TeachReview with the notch in the position it was in when the log file entry was written. You can tell TeachReview to temporarily rotate the displayed wafer to any of four positions: 3, 6, 9, or 12 o’clock. The new orientation remains in effect only for the log file entry currently displayed. As soon as you change to a different log file entry, the wafer orientation changes to the orientation recorded in the log file as part of the log file entry.

The displayed X and Y readings are always relative to the horizontal X axis and vertical Y axis of the video image, regardless of the orientation of the wafer. For example, let’s assume you have readings of X=-1.5 mm and Y=2.0 mm with the default orientation (notch at 3 o’clock). If you change the wafer orientation so that the notch is at 6 o’clock, the readings will change to X=2.0 mm and Y=1.5 mm.

To temporarily change the orientation of the wafer in the TeachReview display:

- Choose the desired orientation from the Notch at: menu in the Readings section of the display (Figure 4.5).

![Figure 4.5: Changing the Wafer Orientation](image)
Changing Log Files

You can open a log file using the Open Log File command on the File menu, as described in “Running TeachReview,” on page 4.2. If you have previously opened files in TeachReview, the last few files you opened are listed in the Viewing log file menu. That gives you a quick way to select a recently opened log file (see Figure 4.6). If you don’t see the file you want in the list, choose Browse at the end of the list to open the log file.

Figure 4.6: Selecting a Log File
Displaying Station and Wafer Information

Operator, Tool, Station, and Comment are user-specified text in TeachView that can be recorded in a log file along with the other data. You can display this information, along with the serial number of the wafer and the number of days since calibration.

To display this information for a log file:

1. Choose the Settings > Show Station Information menu item.

   The Station Information dialog is displayed, as shown in Figure 4.7.

![Station Information Dialog](image)

Figure 4.7: Station Information Dialog

You can leave the Station Information dialog open while using TeachReview, or you can click Close to close the dialog.
Printing the TeachReview Window

You can print an image of the TeachReview window to have a graphical record of the session.

To print an image of the TeachReview window:

1. Choose File > Print.
2. In the Print dialog, click OK.

You can also select a printer other than the default and change the printer setup, or see a preview of what TeachReview will print:

- To select a different printer, to change the paper selection or print orientation, or to set printer properties, choose the File > Print Setup menu item.
- To see a preview of what TeachReview will print, choose the File > Print Preview menu item.
Creating Target Configuration Files

ATS helps you adjust wafer handling equipment so that the equipment can pick up a wafer or put down a wafer in exactly the right position. To determine the correct position, ATS uses a target, which is a round physical feature inside the equipment that ATS can recognize and precisely locate. To recognize a target, ATS requires a target configuration file. A target configuration file must contain information that is very specific to a particular target. The two key pieces of information ATS needs are the diameter of the target and the distance from the wafer to the target. Of the two, specifying an accurate target diameter is the most critical. If two pieces of equipment have identical targets and wafer-to-target distances, you can use the same target configuration file for both; otherwise, you need to create separate target configuration files. The TeachTarget application is designed specifically for the task of creating target configuration files.
Choosing a Target

Before you can create a new target configuration file, you need to decide which feature of the equipment to use for the target. Look for a hole or similar round feature that is located in the center of the equipment. A feature with a diameter of a few millimeters up to a few centimeters works best. A target that fills between 1/8 to 1/3 of the view generally gives better results. The target must be small enough that the entire target is visible in the video image in TeachTarget.

When you use TeachTarget, if the target you choose is too small, the application will ask you to identify a secondary target. The secondary target must be concentric with the primary target. For example, if a piece of equipment has a 4-mm hole and 30-mm ring, you could specify the 4-mm hole as the primary target; if TeachTarget requests a secondary target, you would specify the 30-mm ring for the secondary target. If your equipment doesn’t have a feature that could be used as a secondary target, TeachTarget will just do the best it can using the primary target.
Measuring the Target

The TeachTarget application will ask for two critical target measurements:

- **Target diameter.** The diameter of the target in millimeters. This is the most critical measurement and should be accurate to 0.01 mm.
- **Target distance.** The distance (Z), in millimeters, from the bottom of the teaching wafer to the target. This measurement should be accurate to 0.5 mm.

More accurate you can make these readings give better results, so make them as accurate as you reasonably can.
Running TeachTarget

To create a target configuration file:

1. Choose the feature of the equipment you will use for the target (see “Choosing a Target,” on page 5.2).
2. Get the target measurements (see “Measuring the Target,” on page 5.3).
3. Place the teaching wafer on the equipment. Align the teaching wafer so it matches the TeachTarget display by rotating the wafer until the WaferSense™ ATS logo is right-side up and level as you face the wafer, as shown in Figure 5.1.

4. If TeachView is running on the computer, exit the application. At any given time, only one application can communicate with the teaching wafer.
5. From the Windows Start > All Programs menu, choose WaferSense ATS > TeachTarget.
6. Make sure the computer running the TeachTarget application is within the range of the link module, about 30 ft (10 m).
7. Resize the TeachTarget window until the target feature in the video image is easy to see. Use the DARKER and LIGHTER buttons in TeachTarget to adjust the image so that you can distinguish the target from the background. This adjustment is only for your convenience; it doesn’t affect the creation of the target configuration file.

Figure 5.1: Aligning the Teaching Wafer
8. **Step 1, Position the Wafer.** Move the teaching wafer until the red cross hairs are centered on the target, as shown in Figure 5.2. When the cross hairs are centered, click **Next**.

![Figure 5.2: Step 1. Position the Wafer](image-url)
9. **Step 2, Optimize Lighting.** TeachTarget performs this step all by itself. When **Optimization complete** is displayed below the indicator bar (see Figure 5.3), click **Next**.

![Figure 5.3: Step 2. Optimize Lighting](image-url)
10. **Step 3, Acquiring Image.** TeachTarget performs this step all by itself. While the image is being acquired, no video image is displayed. When the step is complete, the video image appears and TeachTarget displays **Image retrieval complete** below the indicator bar (see Figure 5.4). Note that from this point on, the image displayed in TeachTarget is the captured image, rather than live video. When you are ready to proceed, click **Next**.

![Image retrieval complete](image)

**Figure 5.4: Step 3. Acquiring Image**
11. **Step 4, Target Parameters.** Figure 5.5 shows a dark target on a light background. If you have the opposite situation, check the box **Light target on dark background.**

![Figure 5.5: Step 4. Target Parameters](image)

12. Enter the diameter of the target and the distance from the bottom of the teaching wafer to the target (Z distance). For more information on these values, see “Measuring the Target,” on page 5.3. You can enter the values in either inches or millimeters by choosing the appropriate **Units** (see Figure 5.5). After entering the values, click **Next**.

13. If the image of the target is too small for good recognition (fewer than 80 pixels in diameter), TeachTarget asks you to identify a possible secondary target (for more information on secondary targets, see “Choosing a Target,” on page 5.2). If you have a feature that you can use for a secondary target, fill in the diameter of the target feature in the **Secondary target** area. If the equipment doesn’t have a secondary target feature, fill
in zero, and TeachTarget will use the primary target. After entering the secondary target value, click **Next**.

**Figure 5.6: Step 4. Secondary Target Parameter**
14. **Step 5, Overlay Alignment.** For this step, you'll find it helpful to have a very large video image, so resize the TeachTarget window to make the video image as large as possible. TeachTarget adds two concentric red overlay rings to the captured image of the target (see Figure 5.7). If you identified a secondary target in the previous step, TeachTarget adds the red rings to the secondary target, as shown in Figure 5.8 on page 5.11.

15. If the rings aren't centered on the target, use the **Ring position** buttons to center them.

16. Use the **GROW** and **SHRINK** buttons to adjust the size of the rings until they just enclose the edge of the target feature (see Figure 5.7). For a secondary, ring-shaped target, choose either the target’s inner edge or outer edge to enclose with the red rings (see Figure 5.8 on page 5.11).

![Figure 5.7: Step 5. Overlay Alignment, Primary Target](image-url)
When you have the rings aligned on the target, click **Next**.

**Figure 5.8: Step 5. Overlay Alignment, Secondary Target**
18. **Step 6, Generating Target Parameters.** TeachTarget immediately begins generating the parameters for the target configuration file (see Figure 5.9). When the parameter generation is complete, click **Save Target File**, fill in a name for the file, and click **Save**. By default, target configuration files are saved in *c:\Documents and Settings\All Users\Application Data\CyberOptics Semiconductor\ATS\Target Files*.

![Figure 5.9: Step 6. Generating Target Parameters](image)

19. When you have finished saving the file, click **Done**. TeachTarget exits.

The target configuration file you just created is ready to use. Be sure to click **Done** to exit TeachTarget, or use the menu **File > Exit**, before running TeachView. Only one application at a time can communicate with the teaching wafer.
Chapter 6

Maintaining Your ATS

This chapter discusses the following:

- Annual factory calibration and battery replacement
- Battery use and disposal
- Updating your ATS wafer firmware

**Warning**
The edges of the ATS teaching wafer are thin. It may be possible to sustain an injury from these edges if the teaching wafer is not handled with proper care.

**Warning**
Protection afforded by compliance to EN61010-1 (2001) may be impaired if the equipment is not used as specified.

**Warning**
When operating the ATS in vacuum, high speed venting or pump-down may cause the ATS to turn off. This will not damage the ATS. If necessary reduce vent speed, turn on again, and repeat the procedure.

Periodic calibration and battery replacement is the only regular maintenance your ATS requires:

- **Annual Calibration and Battery Replacement.** Once a year, you should have your teaching wafer calibrated and the internal rechargeable battery replaced by returning the teaching wafer to the CyberOptics Semiconductor factory.

- **Cleaning the Teaching Wafer.** If cleaning is required, wipe the outside of the teaching wafer with IPA (isopropyl alcohol). If the teaching wafer is used in a clean environment, follow proper procedures for cleaning devices for this environment.
Chapter 6. Maintaining Your ATS

**Annual Factory Calibration and Battery Replacement**

Every twelve months, you should return your teaching wafer to the CyberOptics Semiconductor factory, where we will calibrate the teaching wafer and replace the internal rechargeable battery. You can find the date when the teaching wafer was last calibrated at the factory by choosing the **Help > About your ATS Wafer** menu item in the TeachView application.

When the date for calibration approaches, the TeachView application will occasionally notify you by displaying the ATS Wafer Calibration Status dialog, as shown in **Figure 6.1**.

![ATS Wafer Calibration Status Dialog](image)

**Figure 6.1: ATS Wafer Calibration Status Dialog**

If you drop the teaching wafer or suspect that it is no longer in calibration, contact CyberOptics Semiconductor technical support (see “**Technical Support,** on page 2.9”).
Battery Use and Disposal

Your ATS teaching wafer contains a lithium-polymer battery. To avoid damage to the teaching wafer, use the supplied charger only. Do not charge the teaching wafer at temperatures outside the specified range (0 °C to 45 °C). Do not incinerate or dispose of the teaching wafer into fire. Do not immerse the teaching wafer when cleaning or spill liquids on the teaching wafer.

For proper battery disposal, please contact technical support (see “Technical Support,” on page 2.9).
Chapter 6. Maintaining Your ATS

## Updating Your ATS Wafer Firmware

Your ATS includes a software application, called ATS Firmware Updater, for updating the firmware that is onboard the ATS teaching wafer. The current firmware version is available by choosing the **Help > About your ATS Wafer** menu item in either TeachView or TeachTarget.

To update the firmware on your ATS teaching wafer:

1. Turn on the teaching wafer.
2. If either TeachView or TeachTarget is running on the computer, exit the application.
3. From the Windows **Start > All Programs** menu, choose **WaferSense ATS > ATS Firmware Updater**.

   The ATS Firmware Updater application starts, as shown in [Figure 6.2](#).

4. In the ATS Firmware Updater window, verify that the battery level is at least 50%. You can’t update the firmware if the battery level is below 50%. If necessary, recharge the battery before proceeding (see [“Charging the Battery,” on page 3.21](#)).

[Figure 6.2: Starting the ATS Firmware Updater Application](#)
5. Click **Select Firmware File**.

6. In the ATS Firmware File dialog, find and select the firmware file and click **Open**. By default, the ATS Firmware Updater looks for firmware files in `c:\Documents and Settings\All Users\Application Data\CyberOptics Semiconductor\ATS\Firmware\`.

   **Caution**

   In the next step, you will start the load firmware process. Once you start the process, the firmware is automatically uploaded to the wafer, committed, and verified. Do not interrupt this process by turning off or cycling the power to the teaching wafer. If you do so, the wafer might be disabled, and you will need to return it to the factory to fix the problem.

7. Click **Load Firmware**.

   The firmware file is uploaded to the wafer, committed, and verified. This process takes a few minutes, and the ATS Firmware Updater displays progress bars and messages so you can follow the progress. When the firmware has been verified, you will be prompted to cycle the power on the teaching wafer, as shown in **Figure 6.3**.

   ![ATS Firmware Updater](image)

   **Figure 6.3: Cycle Power dialog**

   8. Press the **ON OFF** button on the teaching wafer to turn off the wafer, then press it again to turn on the wafer. The teaching wafer doesn’t start using the new firmware until you cycle the power.

   9. Click **OK** to close the dialog.

   10. Choose **File > Exit** to exit from the ATI Firmware Updater application.
Specifications

System Requirements

To run the WaferSense ATS software and link, your computer must have:

- Windows XP, Windows Vista (32/64), or Windows 7 (32/64) operating system
- One free high-power USB 1.1 or USB 2.0 port

ATS Hardware

Environmental

Operating pressure range: \( \leq 10^{-6} \) Torr to atmospheric.

Storage temperature range: -20 °C to 70 °C.

Charging temperature range: 0 °C to 45 °C

Operating temperature range: Optimum 20 °C to 50 °C. Can withstand exposure to 120 °C (5 minutes or less) if not in direct contact with heating element.

Power

Battery charger requires 100 - 240 VAC at 47 - 63 Hz input.

Battery usage on a full charge: approximately 2 hours. Battery performance degrades at temperatures outside the optimum operating temperature range.

Typical battery recharge cycles: approximately 500.

Range and Accuracy

X and Y accuracy: ±0.1 mm (±0.004")

Z range: 6.4 mm to 45 mm (0.25" to 1.8")

Z accuracy: ±0.5 mm (±0.02")
Index

A
About TeachView dialog 2.9
About your ATS Wafer dialog 2.9
accuracy of measurements 6.1, 7.1
ATS
installing 2.1
specifications 7.1
system components 1.1
ATS Firmware Updater 6.4–6.5
automatic shutoff, teaching wafer 2.5, 3.2

B
battery 3.21
care and disposal 6.3
recharging 3.21
replacement 6.1
Bluetooth wireless link 1.1, 3.23
buttons on teaching wafer 3.2

calibration 6.1
teaching wafer calibration date 2.9
Charging Done status light 3.2
Charging status light 3.2
cleaning the teaching wafer 6.1
Comment, including in log file 3.17
communications, initializing 2.7, 6.4
components, ATS 1.1
Connection Status light 3.2

displaying log entries 3.18

F
FCC standards ii
finding a target 3.3, 3.10
firmware version 6.4
firmware, updating 6.4

H
hardware specifications 7.1

I
ignore target Z value 3.12, 4.6
inch units 3.11, 3.12, 4.5
installation
ATS 2.1
firmware, updating 6.4
link module 2.3
software 2.2
system requirements 2.2

L
link module
changing pairing with teaching wafer 3.24
installation 2.3
monitoring the connection 3.23
NEW PAIR button 3.24
status lights 2.4, 2.5, 3.24
USB port 2.2
Log a Reading button 3.16
log file 3.18
log files
changing 4.8
viewing in TeachReview 4.2
logging readings 3.15
Index

Comment 3.17
displaying log entries 3.18
log file 3.18
Operator 3.17
Station 3.17
Tool 3.17
user-specified information 3.17

M
maintaining the teaching wafer 6.1
millimeter units 3.11, 3.12, 4.5
monitoring the wireless connection 3.23

N
NEW PAIR button 3.2, 3.24
notch location 3.13, 4.7
numeric readouts 3.5

O
ON OFF button 2.5, 3.2
On status light 3.2
operating temperature, monitoring 3.20
Operator, including in log file 3.17
optimize lighting 3.6, 3.8
orientation of wafer 3.13, 4.7

P
Pair Status light 3.2
pairing of teaching wafer and link module,
changing 3.24
preferences, see settings
printing 3.19, 4.10

R
radio interference ii
rechargeable battery 3.21
   recharging 3.21
   replacement 6.1
registering your teaching wafer 2.6
rotating the wafer display 3.13, 4.7

S
saving settings 3.25
serial number, teaching wafer 2.9
settings
   log file 3.18
   optimize lighting 3.6, 3.8
   saving 3.25
   target configuration file 3.5
   target criteria 3.11, 4.5
   wafer display orientation 3.13, 4.7
shutoff, automatic 2.5, 3.2
software installation 2.2
software version 2.9
specifications 7.1
starting TeachView 2.7
Station, including in log file 3.17
status lights
   link module 2.4, 2.5, 3.24
   teaching wafer 2.5, 3.2, 3.24
support 2.9

calibration 6.1
changing pairing with link module 3.24
   cleaning 6.1
firmware 6.4
maintenance 6.1
monitoring the connection 3.23
NEW PAIR button 3.24
recharging the battery 3.21
registering 2.6
serial number 2.9
status lights 2.5, 3.2, 3.24
TeachReview 4.1–4.10
TeachTarget 5.1–5.12
TeachView 3.1–3.25
  main window 3.3
  software installation 2.2
  starting the application 2.7
  version 2.9
technical support 2.9
temperature, monitoring 3.20
Tool, including in log file 3.17

U
units, mm or inches 3.11, 3.12, 4.5
USB port 2.2, 2.3

V
version of firmware 6.4
version of software 2.9
video
  frozen image 3.8
  optimize lighting 3.6, 3.8

W
Windows operating system 2.2
wireless link, see link module
wireless technology 3.23